Je me suis enfin penché sur la mise à niveau de Dotclear.
La version 2 beta 3.1 m'avait résisté et du coup j'avais à l'époque laissé tomber. Et aujourd'hui je m'aperçois que le père Noël est passé par là et que la version 2 beta 4 a été publiée le 26 décembre (ils sont fous les gars qui codent Dotclear :)). Bref je le teste rapidement et tombe sur le même problème que pour la 2 beta 3.1. Une investigation rapide et la bonne doc de Dotclear m'ont permis de trouver qu'il me manquait un package sur mon serveur (php-dom-5.1.6-1mdv2007.0).
Maintenant tout semble fonctionner et je n'ai pas constaté de disfonctionnement sur le blog. Si jamais vous en voyez, n'hésitez pas à me le signaler ;)

Si vous souhaitez plus d'information sur cette dernière version de Dotclear, lisez ce billet sur le site officiel.